Technical Help

To fully experience our web services as intended, Cater Allen recommend customers use the latest version of their chosen web browser.

If you are upgrading your web browser we recommend the latest free versions of Internet Explorer, Chrome, Firefox or Safari.

If you have any technical problems downloading a browser, please contact either your Internet Service Provider or Computer Manufacturer.

For more details on how to get the best from the Cater Allen website, please read the information below.

Screen Resolution

The Cater Allen site is best viewed at a resolution of 1024x768 pixels or greater. In order to change the screen resolution on Windows 7, go to Start>Control Panel>Appearance and Personalization> click the drop-down list next to resolution and move the slider to the resolution you want and click Apply. Click Keep to use the new resolution or click Revert to go back to the previous resolution.

On a Mac, go to Apple Menu>System Preferences>Displays. Then click Display, click Scaled and select the resolution you want.

Partially Sighted Customers

Cater Allen has improved the accessibility of its website for blind and partially sighted customers. We have done this through the use of our own website accessibility guidelines in consultation with the RNIB and by following as far as possible, the guidelines established by the official Web Accessibility Initiative (WAI).

Windows PC Requirements

To use the site effectively your PC should operate one of the following web browsers:

  • Microsoft Internet Explorer 8 or greater
  • Google Chrome (the latest version)
  • Mozilla Firefox (the latest version)

Mac Requirements

To use the site effectively your Mac should operate one of the following web browsers:

  • Safari (the latest version)
  • Google Chrome (the latest version)
  • Mozilla Firefox (the latest version)

Other Browsers

The Cater Allen site is optimised for use with the browsers listed above and whilst we do everything we can to make the site accessible to all it may not display correctly in older versions or other browsers.